Forum rules and expectations

Hello, and welcome to the forums at the Nautilus Drydocks, formerly!

We welcome anyone with a passion for submarines and a desire to learn and share knowledge about this fascinating hobby. Use of these forums indicates your intention to abide by our code of conduct:

1. No spam. All automated messages, advertisements, and links to competitor websites will be deleted immediately.

2. Please post in relevant sub-forums only. Messages posted in the wrong topic area will be removed and placed in the correct sub-forum by moderators.

3. Respect other users. No flaming or abusing fellow forum members. Users who continue to post inflammatory, abusive comments will be deleted from the forum after or without a warning.

4. No threats or harassment of other users will be tolerated. Any instance of threatening or harassing behavior is grounds for deletion from the forums.

5. No profanity or pornography is allowed. Posts containing adult material will be deleted.

6. No re-posting of copyrighted materials or other illegal content is allowed. Any posts containing illegal content or copyrighted materials will be deleted.
See more
See less

Help no reverse Viper micro 10

  • Filter
  • Time
  • Show
Clear All
new posts

  • Help no reverse Viper micro 10

    As I slowly put my type 7 together (sub-driver electronics portion) I have gotten the radio and devices working but the motors will only go in one direction. I think forward. I have found instructions on the net for fine tuning/set-up. but I cannot get the esc to go into that mode. when holding the set-up for one second nothing happens.

    any guidance would be appreciated.

  • #2
    Steve of Mtronics says --

    Hi Mike.

    Sounds strange. It shouldn't be a unit with a reverse-off option, we haven't
    made any like that for a long time. His 'holding the button for a second'
    puzzles me - it only needs a quick press during the power-up-LED-flickering
    window to enter setup mode - which I suspect is where the customer needs to

    Also, try reversing the motor's polarity to make sure it isn't one with
    deranged timing that prevents it running in one direction.

    Best regards, Steve.
    Stop messing about - just get a Sub-driver!


    • #3
      I have attempted to perform the set-up with a quick test during the flashing of both the red and green. works fine except when I move the stick to reverse all I get is a red led.

      I have tried other radios(to test) with it and I get the same thing.

      Also not sure what you mean when you say deranged timing.

      I have had several ESC's and never experienced something like this.

      Is it possible that the ESC is defective ?

      Auburn, WA USA


      • #4
        What they mean by deranged timing is for the motor not the esc. You may simply have a bung can which though rare can happen. Since you have tried other radios then it's not a trim switch or EPA adjustment issue my next action would be to disconnect the motor from the esc and connect it to a battery with alligator clips so you can swap the polarity to see what it does. If it only spins one direction regardless of polarity then your can is buggered.

        Reality is but a dream...
        But to dream is a reality


        • #5
          Thanks for the reply.

          I had read in some detail about the EPA's and ruled those out. I did disconnect the motors from the speed control, then reversed the polarity and the motors worked (turning in the opposite direction yet now won't go the other direction.

          I am thinking that my ESC is defective. I got the same conditions as I mentioned before on the ESC (red light only) when x-miter stick opposite direction.

          I also tried several different channels on the radio all with the same result.